
 

CHAPTER 3 
ARRANGING SHAPES 

 

In This Section… 
 Several techniques for creating guidelines 
 Show how to align shapes to the grid 
 Note how to reset the grid after it has been 

resized 
 Alignment of shapes 
 Creating arrays of shapes 
 Using Start Sequence to arrange shapes 
 Nesting shapes to minimize wasted media 
 Serializing text data using badges 
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GUIDELINES 
When dragging shapes, guidelines are used for 
precise alignment. A shape will "snap" to the 
location when it is dragged over a guideline. 

 

 When there is no selection, right-clicking on 
the workspace will open the Edit Guides 
dialog. 

 Under the Options menu, choosing Guides | 
Edit Guides will open the Edit Guides dialog. 

 Right-clicking a ruler will create a guide. 
 For a selected shape, press [Shift] and right-

click the shape nubs to create guides (not when 
editing a parametric shape). 

 To add guides when node editing, press [Shift] 
and right-click the node. 

 When dragging a guide, press [Shift] to 
constrain the guide to the nearest ruler 
increments. 

 To lock guides in place, open the Edit Guide 
dialog and check the Lock Guides checkbox. 

 To temporarily hide the guides, choose 
Options menu | Guides | Use Guides. The 
shortcut to toggle guides On/Off is [Alt + W]. 

 To remove a guide, press [Shift] and right-
click the guide (when there are no objects 
selected). 
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THE GRID AND ALIGN PALETTE  
Press the [Control] key and right-click the 
workspace to display the Align Palette, which is 
used to align shapes with respect to the grid. 
Typically, these tools are applied to shape nubs, 
though they may also be used when node editing. 

 

  Set Origin: Set the grid origin to the 
selected location. 

  Resize Grid: Resize the grid increments 
based on the distance between the selected 
location and the grid origin. 

  Snap to Grid Intersection: Move the 
shape, such that the nub is at the nearest grid 
intersection. 

  Snap Vertically: Move the shape, such 
that the nub is at the nearest horizontal grid 
line. 

  Snap Horizontally: Move the shape, 
such that the nub is at the nearest vertical grid 
line. 
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From the Options menu, the Reset Origin 
command will set the grid size according to the 
General Preferences setting. This is useful when 
the Set Origin or Resize Grid commands have 
been used. 

 

ALIGNMENT HOT KEYS 
To align selected shapes quickly, use the following 
hot keys: 

 

 [Alt + 1] Align shapes along left edge of 
bounds 

 [Alt + 2] Center shapes vertically 

 [Alt + 3] Align shapes along right edge of 
bounds 

 [Alt + 4] Align shapes along top edge of 
bounds 

 [Alt + 5] Center shapes horizontally 

 [Alt + 6] Align shapes along bottom edge 
of bounds 

 [Alt + 7] Center shapes both horizontally 
and vertically 
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To align shapes to the sign blank, use the following 
hot keys: 
 

 [Alt + Insert] Align with top edge of 
sign blank 

 [Alt + Home] Center vertically along 
width of sign blank 

 [Alt + Page 
Up] 

Align with bottom of 
sign blank 

 [Alt + Delete] Align with left edge of 
sign blank 

 [Alt + End] Center horizontally 
along height of sign 
blank 

 [Alt + Page 
Down] 

Align with right edge of 
sign blank 

 
To align shapes to the last object, use the following 
hot keys. 
 

 [L] Left – Align with the left 
edge of the last object. 

 [R] Right – Align with the 
right edge of the last 
object. 
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 [T] Top – Align with the top 
edge of the last object. 

 [B] Bottom – Align with the 
bottom edge of the last 
object. 

 [E] Horizontally – Center 
horizontally along height 
of last object. 

 [C] Vertically – Center 
vertically along width of 
last object. 

 
 

ALIGNMENT 
From the Layout menu, the Alignment and Align 
commands are available from the Arrange and 
Distribute flyout. The Alignment command is 
used to change the alignment settings, whereas the 
Align command will apply the most recently used 
alignment settings. 

 

  Align to signblank: Shapes are aligned 
relative to the signblank 
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  Align to grid: Shapes are aligned relative 
the grid lines 

  Align to last object: For several selected 
shapes, align the shapes according to the last 
shape selected in the group 

  Align to selected: For several selected 
shapes, align the shapes according to the 
bounding box that is around the selection 

 

When aligning text shapes, the following options 
are also available: 

 

  Treat Text Line as an Object: Enabled 
when using equal vertical spacing. For a text 
paragraph that has multiple lines, this option 
will cause each line to be aligned separately. 

  Ignore Descenders: Enabled when using 
equal horizontal spacing. Causes the text 
descenders to be ignored, such as for letters ‘j’, 
‘p’, and ‘q’. Alignment is performed with 
respect to the text baseline. 
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ARRAY 
From the Layout menu, the Array command is 
used to arrange multiple copies into rows, columns, 
or arcs. 

For shapes arranged on an arc, specify the arc 
radius and the range of angles over which the 
copies are spread. 

When creating an array, the copies can be 
automatically rotated. The Spin Each option will 
rotate each subsequent copy by the Spin Amount. 
The Total Spin option will progressively rotate 
each copy, such that the final copy is rotated by the 
Spin Amount. 

 

 Vertical  
 Staggered  

 Horizontal  

 Grid  

 On arc  

 On arc with rotate  
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START SEQUENCE 
From the Layout menu, the Start Sequence 
commands are available from the Sequence flyout: 
Start Sequence, Start Sequence by Vector, and 
Start Sequence by List. 

The Start Sequence command has two uses. The 
first usage is to arrange the database order of the 
shapes, which determines the order in which the 
shapes are output to a printer or cutter. The second 
usage is to arrange shapes graphically on-screen. 

 

Creating a Sequence 
1. Select the first shape. 
2. From the Layout menu, choose Sequence, and 

Start Sequence. 
3. Click each subsequent shape, one-by-one. A 

connecting line is drawn as each shape is 
clicked. 

4. Click on an empty portion of the workspace to 
finish editing. 

 

The Start Sequence by Vector command is similar 
to the Start Sequence command, except that 
multiple shapes are added to the sequence by 
drawing a line.  

 

Chapter 3 : Arranging Shapes 37 



 

Creating a Sequence by Vector 
1. Select the first shape. 
2. From the Layout menu, choose Start 

Sequence by Vector. 
3. Click and drag the cursor to form a line. All 

shapes that are intersected by this line will 
become part of the sequence. 

4. Click on an empty portion of the workspace to 
finish editing. 

 

Both the Start Sequence and Start Sequence by 
Vector commands can be used to arrange shapes. 
Repeat steps (1-3), and then right-click and drag the 
shapes across the workspace. 

The Start Sequence by List command will open 
the Sequence by List dialog, which provides a 
visual list of all the shapes that are on the 
workspace. Shapes at the front of this list will 
appear above other shapes, and shapes at the back 
will appear below. The mouse can be used to drag 
shapes within this list. Alternatively, select a shape 
and use the To Front, To Back, Forward One, 
and Back One buttons. To use the Reverse Order 
button, at least two shapes must be selected. 
 

 Holding the [Shift] key will align the shapes 
according to their lower-left bounding box 
corner. 
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 Holding the [Control] key will constrain the 
shapes either vertically or horizontally. 

 

NESTING 
From the Arrange menu, the Nesting command is 
used to rearrange shapes into the minimum area 
necessary for printing or cutting the shapes. In this 
manner, the amount of wasted media required to 
output the shapes is minimized. Nesting may also 
be used to rearrange shapes across a non-
rectangular area, such as leftover media. 

To nest the individual letters of a sentence, the Text 
to Graphics command must be used first. 
Otherwise, the entire sentence will be nested 
without rearranging the individual letters. 

 

  Specify Corners: Choose the 
corner from which rearranged shapes will be 
placed. Nesting will begin in that corner and 
extend across the sign blank. 

  Directions: The direction in which 
shapes will be nested across the material. 
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  Rotation: Allow 
rotation of shapes by the specified maximum 
number of degrees. If 20 degrees, then shapes 
will be rotated in increments of 20 degrees to 
find the optimum placement. 

  Nesting Border: The 
minimum distance to maintain from the 
material edge. 

  Clearance Between 
Objects: The minimum distance between 
shapes. 

  Error Factor of 
Clearance: For expert SignLab users, a value 
that is used to adjust nesting based on the 
average shape sizes. 

  Allow Mirrored Parts: Allow objects to 
be flipped horizontally or vertically during the 
nesting process. 

  Keep Groups Intact: If this option is 
off, then grouped shapes will be separated 
during the nesting process. 
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  Block Nesting and True Shape 
Nesting: Note that each shape has a 
rectangular bounding area. Enabling this 
option will prevent the bounding areas from 
overlapping (Block Nesting). If this option is 
OFF, then nested shapes will ignore the 
bounding areas (True Shape Nesting). 

  Nest Inner Contours: Allow shapes to 
be nested within the inner contours of other 
shapes. 

  Select a Shape: By default, shapes are 
nested across the Blank Size. Click this option 
to select a different shape for nesting. 
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Error Factor of Clearance 
During the nesting process, approximations are 
made that are based partly on the magnitude of the 
shapes being nested. Setting a small Error Factor 
will produce more consistent spacing between the 
shapes, but at a cost of more processing time. The 
following chart provides suggested Error Factor 
values, which are qualified by the broad categories 
of Fine, Medium, and Coarse. The table is based 
on the average dimension (inches or millimeters) of 
the shapes being nested. 

 

Shape Dimension Fine Medium Coarse 

0 < Size < 100 0.1 0.2 0.5 

100 < Size < 1000 0.2 0.5 1.0 

1000 < Size < 3000 0.5 1.0 2.0 

Size > 3000 1.0 2.0 5.0 
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Selecting a Shape for Nesting 

1. Create and resize a rectangle shape to match 
the area that shapes will be nested within. 
(Any vector shape is fine. We are using a 
rectangle as part of this example). 

2. Select the shapes that will be nested. However, 
do not include the rectangle as part of the 
selection. 

3. From the Arrange menu, choose the Nesting 
command. The Nesting dialog will open. 

4. In the Nesting dialog, click the Select a shape 
button. The Nesting controls will now remain 
unresponsive until either the rectangular shape 
from step (1) is selected, or the Select a shape 
button is clicked again. 

5. Click the rectangular shape. 

6. The Nesting controls will become active 
again. Adjust the other Nesting controls, and 
then click OK to continue. 
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BADGES 
From the Layout menu, the Badges command is 
used to serialize text data. For example, badges are 
used to create name plates for doors, identification 
cards for employees, and adhesive labels for 
schematics. 

From the Badge Setup dialog, the Blank fields 
indicate the Width, Height, and Margins that will 
be used when distributing the badges across the 
sign blank. The Spacing fields, Vertical and 
Horizontal, indicate the amount of space to 
maintain between badges. 

The Page Preview shows how the badges will be 
distributed across the sign blank. Badges can be 
arranged either vertically (top-to-bottom), or 
horizontally (left-to-right). 

The Use Score Lines option is used to insert score 
lines between each badge, so as to improve the ease 
of separating the badges after production. Use the 
Color picker to set the score line color. 

Enabling the Use Plate option will limit each badge 
to a single sign blank page. If the Use Plate option 
is enabled, then the margins will be cleared to zero. 

Where badges are distributed over more than one 
sign blank, then the Paging Tool is used to browse 
the additional sign blanks. The Paging Tool is at 
the bottom-right corner of the workspace. 
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Tips when Setting Plate Size 
and Margins 

 When routing or engraving, it is recommended 
that the Height and Width be set to the exact 
dimensions of the plate. 

 When rendering a vinyl sign, set the Height 
and Width to match the page size of the 
plotter. 

 When cutting or plotting, set the margins equal 
to the cuttable area of material, not necessarily 
the actual size. 

 

 

The Number of copies indicates the total number 
of badges to be created. The Total Number of 
Pages indicates the number of sign blanks that are 
required to display the badges, and Max copies per 
page indicates the number of badges that can be 
displayed per sign blank. 

If the badge text has been applied with text 
compression, then the Compress Equally Over 
Copies option is available. Enabling this option 
will cause all badges to be evaluated to determine 
the maximum amount of text compression required 
(if any) to fit replacement text within the badge 
margins. For consistency, all badges will then be 
applied with an equal amount of text compression. 
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The Replaceable Items / Text list displays all text 
shapes that are available for substitution. The text 
of each item will correspond to the text that had 
been entered on the workspace. Select the text 
objects that will undergo substitution. If a text 
shape is not selected within this list, then no 
substitution for that text will take place. 

The Replacement Data File contains the text that 
will be substituted for each badge. The order of 
fields in the Replacement Data File should 
correspond to the order of text shapes on the 
SignLab workspace. This will allow the Badge 
Setup dialog to substitute text in the correct order. 

Replacement Data File 
Any text editor may be used to create the 
Replacement Data File. Within the text file, each 
line represents a set of data for one badge. If the 
badge has multiple fields, then each field must be 
separated by a delimiting character, such as a 
comma, a space, or a tab character. For example, 
tab-delimited data might appear as follows: 
 
Text Field 1  [TAB]  Text Field 2  [TAB]  Text 
Field 3 
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Next to the Browse button, the drop-down list may 
be used to choose the delimiting character that is 
used in the text file. 
If there are more badges being created than there 
are sets of data, then the extra badges will be filled 
with empty data. 
 

 

BADGES – TEXT SUBSTITUTION 
From the Badge Setup dialog, click OK to 
continue. If one-or-more text fields were selected 
within the Replaceable Items / Text list, then the 
Text Substitution dialog will open. Each column 
represents one of the items from the Replaceable 
Items / Text list. If a Replacement Data File had 
been specified, then the column entries will be 
filled using data from that file. To type text, select a 
cell and type within the Edit Text field. 

Within the Text Substitution dialog, a column (or 
range of cells within a column) can be serialized. 
For example, click a column header to select all the 
cells within that column. The Serialize dialog will 
open, which is used to indicate the Start value for 
the series, the Increment value between each cell, 
and whether Number or Character values will be 
used. 
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The Start value may be either numeric, alphabetic, 
or alphanumeric. For alphabetic series, the ASCII 
character set is used. When badges have 
incremented through the entire ASCII character set, 
then subsequent badges will continue from the 
beginning of the set. 
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Serializing Data – Set Base 
When serializing badge data, the Start field is used 
as the base value, to which the Increment is added 
for each subsequent badge. By highlighting only 
part of the Start field data, the selection will be 
incremented, and unselected portions will remain 
constant. For example, suppose a series of booth 
labels must be created for a trade show. 
 

 
 
As in the screen shot, the value “Booth A” is typed. 
Using the mouse, only the ‘A’ was highlighted, and 
then the Set Base button was clicked. This 
indicates that the word “Booth” will remain 
constant, while the highlighted portion will be 
incremented for each badge. 
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